Mozilla Memes
Sad Panda is sad that FF 16 doesn’t support md5 Certificate Authorities… which is what Mozilla currently uses.

Sad Panda is sad that FF 16 doesn’t support md5 Certificate Authorities… which is what Mozilla currently uses.

  1. sheericabral submitted this to mozillamemes